ATI Powercolor HD 2400 PCI driver problem.

Forum for all the AMD (Previously ATI) video cards from the past, present and future!

ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Tue Sep 09, 2008 12:59 pm

I'm pretty new here so I start with say Hello.

As the title says, I got some problem getting my new graphic card working with Vista.
I got the idea to install Vista couse' some friends are using it and telling me how "good" it really is, but I realized fast that my old graphic card wasn't "Vista Certified", however, so I went and bought a HD 2400 Powercolor PCI 256mb 64bit DDR2 PRO (bought it couse' it says its Vista Certified).

And when I tried to install the drivers I started with the ones on the CD... In some way it just says that the drivers on the CD won't work, I just thought well never mind then. So I went and downloaded Catalyzt driver, didn't work either.
I also tried go to the driver help at ATIs homepage but they didn't have any drivers for PCI only PCI-e.
Isn't that strange? Creating a card and don't put out the drivers for the card on their page, I think so to be honest.

I got a Dell Dimension 3100, no PCI-e port at least what I know, using Vista 32bit Home Edition.

Anyone knows what the problem is? ATI created a graphic card without any drivers, or is it just me not knowing anything about computers? :)
I hope this is enough of information for those who want to help me out.

Thanks in advance.
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby martini161 » Tue Sep 09, 2008 1:38 pm

the newer pci cards arent created by ati, because pci is so old, the pci versions are kinda like custom by manufacturer, so check on there site
User avatar
martini161
Mr Awesome
Mr Awesome
 
Posts: 3185
Joined: Sat Sep 08, 2007 8:27 pm
Location: Cherry Hill, New Jersey

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Wed Sep 10, 2008 12:01 am

Oh, well, do you think I can use the PCI-e drivers for my card?
Couse' I really can't get any drivers, I've been searching for more then one week and still got nothing.
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Wed Sep 10, 2008 9:30 am

Sorry for posting right after my other, but I got a strange phenomenon.

I went in to:
http://www.powercolor.com/Global/suppor ... odelID=454
and saw there was some pretty new drivers for my card there.

When I tried to extract with ZIP Reader I got a report about it was a damage file or something, but I tried anyway. (I tried with Winzip and Winrar to, didn't work either).

Xerces.jpg
Xerces.jpg (36.93 KiB) Viewed 4573 times

(Swedish)

I got some strange error about xerces-c_2_6.dll... It said that it can't install the drivers couse' the xerces.dll can't work in Windows or something like that. And when I tried to remove it and install it said it needed xerces for the install, so how can you install it?

Please help me, Im nearly starting crying now. Hopefully it's just a small problem that you all computer pros know everything about. O:)
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby martini161 » Wed Sep 10, 2008 1:29 pm

hmm, did you download the vista drivers? and if possible do you think you could give me an exact translation of that?
User avatar
martini161
Mr Awesome
Mr Awesome
 
Posts: 3185
Joined: Sat Sep 08, 2007 8:27 pm
Location: Cherry Hill, New Jersey

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Thu Sep 11, 2008 5:37 am

Yea, I downloaded the Vista drivers.

Translation from the "error":

"C:\Users\Ägaren\Desktop\8501vs32new\Bin\xerces-c_2_6.dll is either not designed running in Windows or it contents a error. Try to install the program again with help from the original installationmedium or contact the programsupplier for support.

I just don't understand whats wrong. When I finally find some drivers they don't work, it driving me nu.t
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby martini161 » Thu Sep 11, 2008 1:42 pm

hmm did you uninstall your old drivers?
User avatar
martini161
Mr Awesome
Mr Awesome
 
Posts: 3185
Joined: Sat Sep 08, 2007 8:27 pm
Location: Cherry Hill, New Jersey

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby DMB2000uk » Thu Sep 11, 2008 2:46 pm

Did you try downloading the drivers from the powercolor site again to make sure that it wasn't a corrupted download?

Dan
Image (<- Clickable)
User avatar
DMB2000uk
Site Admin
Site Admin
 
Posts: 7067
Joined: Mon Jul 18, 2005 5:36 pm
Location: UK

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Fri Sep 12, 2008 12:56 am

Yea, I think all my other drivers are gone. Used a program called "Driver Cleaner" and I think it went out well.

First time I tried download it was just a 4.3 mb file, sounds pretty small to me if it should content drivers, but anyway, now i'm downloading it again and it is up on 24mb, so I think that may been the problem before, that I couldn't download all the files or something.

Hope this will work now : <

Big thanks to you who helped me in this thread!
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Fri Sep 12, 2008 6:19 am

Oh god, it didn't work either.
I downloaded a 40mb and it this time it didn't come up a popup that it was a "damage or corrupted file", but now it says that the drivers don't fit with my card. I'm 100% sure that I took the right drivers, checked carefully, but still it say something about drivers don't fit, VGA, bla bla bla... No one except me bought this card? couse' someone else have to get the same problem as me.
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby DMB2000uk » Fri Sep 12, 2008 6:28 am

I've just tired downloading it and it tells me it is a 52.9MB file.

So you might want to try downloading again till you get the whole thing.

Maybe try getting a download manager or something so that if the download crashes you can just hit resume and not have to download it all again.

Dan
Image (<- Clickable)
User avatar
DMB2000uk
Site Admin
Site Admin
 
Posts: 7067
Joined: Mon Jul 18, 2005 5:36 pm
Location: UK

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby martini161 » Fri Sep 12, 2008 1:33 pm

also when ever i download important stuff like drivers i like to check the MD5 Sum you can find a program that does it in windows here: link
the powercolor site doesn't appear to have one for that driver, but im sure dan would be willing to give you one for comparison :)
User avatar
martini161
Mr Awesome
Mr Awesome
 
Posts: 3185
Joined: Sat Sep 08, 2007 8:27 pm
Location: Cherry Hill, New Jersey

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Sat Sep 13, 2008 6:33 am

Ok, I will try to get the whole file. Martini161, what did you mean with MD5 SUM, is it a download manager of some kind? :)
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby martini161 » Sat Sep 13, 2008 7:58 am

no, an MD5SUM is a number that a program generates based on whats in the file. it is virtually impossible for two different files that are not identical to have the same MD5SUM. that is why it is good for checking that something is not missing from the file and that it has not been tampered with
User avatar
martini161
Mr Awesome
Mr Awesome
 
Posts: 3185
Joined: Sat Sep 08, 2007 8:27 pm
Location: Cherry Hill, New Jersey

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Sun Sep 14, 2008 2:42 pm

Sorry for not being so active, I had some other problems to deal with.

Anyway, I got the whole file now installed it and it looked fine, 52.9mb .
But when I restarted the computer a pop up came up and said:

incompatible.jpg
incompatible.jpg (12.34 KiB) Viewed 4322 times


(Swedish again)
Correct translation: "At least one screen-card on the computer have been inactivated because the driver is not compatible with the VGA-card driver."

I can run Catalyst Control Center and change many options for the card, and in Device Manager it says it work correctly.
But when I try to "use" the card for some games, such as World of Warcraft and Wacraft 3 Frozen Throne, those games lag like hell. When I used my integrated it worked fine, some lagspikes but now it lag like I don't have a graphic card at all. :shock:

Is it the drivers the problem lies in?
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby martini161 » Sun Sep 14, 2008 2:46 pm

did you uninstall the old drivers from your integrated? and try disabling the integrated in the BIOS
User avatar
martini161
Mr Awesome
Mr Awesome
 
Posts: 3185
Joined: Sat Sep 08, 2007 8:27 pm
Location: Cherry Hill, New Jersey

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Mon Sep 15, 2008 1:28 am

Well, I couldn't find the drivers for the integrated one, and I really don't have any idea how you disable it in BIOS, but I went to the Device Manager and inactivated it there, no success.
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Mon Sep 15, 2008 5:17 am

Sorry for posting right after my own, again...

It isn't that I got to have a better processor, or is that just a silly thought? :)
Anyway I got a, budget variant of Intel, Celeron 3.06 GHz.
And if needed (don't think so...) I got 2G RAM also.
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby DMB2000uk » Mon Sep 15, 2008 5:50 am

You should still see videos, they would just be very choppy and not very smooth if something was underpowered.

I'm really stumped as to what is happening here, do you have more than one display connected to the PC?

Are you opposed to a complete reformat and re-install of windows if we can't find the thing that is wrong?

Dan
Image (<- Clickable)
User avatar
DMB2000uk
Site Admin
Site Admin
 
Posts: 7067
Joined: Mon Jul 18, 2005 5:36 pm
Location: UK

Re: ATI Powercolor HD 2400 PCI driver problem.

Postby Ylvahest » Mon Sep 15, 2008 6:46 am

No, im only using 1 display.

Well I can re-install Windows, just that, I bought Vista Home Edition Upgrade Pack, will I be able to just install it or do I have to install like XP first?

And one more thing with the card, on the front page of the package it says "Vista Certified", does it mean i can't use it in XP?
Couse' I think I rather go XP, I only bought Vista for my Wireless didn't work in it. =<
Ylvahest
Legit User
Legit User
 
Posts: 12
Joined: Tue Sep 09, 2008 12:41 pm

Next

Return to AMD Radeon and FirePro Forum

Who is online

Users browsing this forum: No registered users and 0 guests