Motherboard USB issues

Discussion about Intel CPU Motherboards
codyintel
Legit Little One
Legit Little One
Posts: 3
Joined: Fri Mar 08, 2013 9:51 am

Motherboard USB issues

Postby codyintel » Fri Mar 08, 2013 9:58 am

Hi i recently bought a Intel BOXDZ77RE75K motherboard, overall very impressed with it. The only issue I'm having is that the rear usb ports (ones connected to the mobo) seem to drop the connection to my mouse and keyboard frequently. It will make the disconnected , then reconnected sound about 3 times and will start working again. I'm just wondering if there's something I could try to do to fix it. Also both the mouse and keyboard work fine on my laptop. Not sure if it could be a driver issue, I'm pretty sure everything is up to date. Thanks in advance

User avatar
Major_A
Legit Extremist
Legit Extremist
Posts: 3793
Joined: Tue May 15, 2007 2:11 pm
Location: Houston, TX

Re: Motherboard USB issues

Postby Major_A » Fri Mar 08, 2013 10:41 am

Have you tried updating drivers (maybe the BIOS)?
http://downloadcenter.intel.com/SearchR ... DZ77RE-75K

Here are a few USB posts over at Intel's forum.
http://communities.intel.com/message/182738
http://communities.intel.com/thread/36072

codyintel
Legit Little One
Legit Little One
Posts: 3
Joined: Fri Mar 08, 2013 9:51 am

Re: Motherboard USB issues

Postby codyintel » Fri Mar 08, 2013 11:24 am

Yeah when I got it I put all the latest drivers from the Intel website on here along with the bios. I can try again and make sure I did it right. I'm just hoping its not an issue with the board that I would have to send it back to fix.

User avatar
Major_A
Legit Extremist
Legit Extremist
Posts: 3793
Joined: Tue May 15, 2007 2:11 pm
Location: Houston, TX

Re: Motherboard USB issues

Postby Major_A » Fri Mar 08, 2013 6:40 pm

I would get on Intel's support chat. Tell them what's going on and see what they say.
http://www.intel.com/p/en_US/support/contactsupport

codyintel
Legit Little One
Legit Little One
Posts: 3
Joined: Fri Mar 08, 2013 9:51 am

Re: Motherboard USB issues

Postby codyintel » Fri Mar 08, 2013 9:10 pm

I would get on Intel's support chat. Tell them what's going on and see what they say.
http://www.intel.com/p/en_US/support/contactsupport


K thanks for the help

User avatar
KnightRid
Moderator
Moderator
Posts: 3371
Joined: Wed Dec 14, 2005 5:21 am
Location: Dallastown, PA

Re: Motherboard USB issues

Postby KnightRid » Sat Mar 09, 2013 6:11 am

Another thing to try would be to put another USB device on those ports and see if it disconnect/reconnects them also like the keyboard and mouse. If not, then it is something with the keyboard/mouse, If it does, then something with the USB ports or drivers.

Are they wireless? I know my wireless does not work properly when plugged into the back of the computer because somehow the signal gets blocked intermittently and causes almost the same thing you described. If it is bluetooth you should be fine but most people have the normal RF wireless. This would explain why it works on the laptop perfectly and not the desktop too.
Cigar Blog I review for - http://www.stogiereview.com


Return to “Intel Motherboard Forum”

Who is online

Users browsing this forum: No registered users and 0 guests