ATI CATALYST 4.7

Forum for all the AMD (Previously ATI) video cards from the past, present and future!
User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33806
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

ATI CATALYST 4.7

Postby Apoptosis » Wed Jul 07, 2004 4:03 pm

CATALYST 4.7 is now available on http://www.ATI.com. This 7th posting of 204 brings us some of the usual CATALYST goodness in the form of Performance, Features and Stability.

Performance:


· Further improvements in our Vertex Shader handling bring performance improvements to applications that use stencil shadow volumes. For example, the Battle of Proxycon and Troll's Lair tests gain 10-30% on RADEON™ X800 PRO.

· Calls of Duty framerates improve 5-10% when anti-aliasing is enabled on RADEON™ X800-series products.

· Aquamark performance is up slightly (2-3%) on RADEON™ X800-series products.

Features:

· This release introduces a new feature called Temporal Anti-Aliasing. OpenGL and Direct 3D applications will benefit from this feature when custom settings for Anti-Aliasing are used, and Temporal Anti-Aliasing is enabled. The feature provides higher Anti-Aliasing quality when an application frame rate is 60 frames per second or higher.

Stability:

· Setting the D3D option to Optimal Quality and configuring the game Freedom Fighters to 1280x1024 no longer results in display corruption being seen on the test resolution window. This issue occurred under Windows XP with an ALL-IN-WONDER™ 9200 installed

· The water that surrounds Death Island in the game Halo: Combat evolved is now seen as blue in colour. This issues was known to occur under Windows XP with an ATI RADEON™ 8500 installed

· Image rendering issues in the Truform room found in Serious Sam are no longer noticed when increasing the Truform level to maximum under the Advanced Rendering Option

· Flashing textures in the water are no longer noticed when running Splinter Cell Pandora Tomorrow under Windows XP with an ATI RADEON™ X800 XT installed

· Playing the game TOCA Race Driver under Windows XP no longer results in the shadows being missing under the car when the shadow quality is set to high


Mr. Chan
Legit Aficionado
Legit Aficionado
Posts: 64
Joined: Tue Jul 06, 2004 2:24 pm
Location: North Carolina
Contact:

Postby Mr. Chan » Wed Jul 07, 2004 6:59 pm

cant wait to try these out, i was just looking and wishing for new ones yesterday! lol...im waiting for the far cry issue to be resolved, lol :)
P4C800-DX
P4 2.4C (2952Mhz)
Corsair 2x256MB-XMS3200C2-PT
Radeon 9600 Pro
Windows XP Professional

User avatar
Bio-Hazard
Legit Extremist
Legit Extremist
Posts: 2302
Joined: Thu May 06, 2004 9:48 pm
Location: Back Woods Of MO.

Postby Bio-Hazard » Wed Jul 07, 2004 8:46 pm

Already got them and loaded, no benchs yet, but they seem to be working fine.............. :D 8)

Mr. Chan
Legit Aficionado
Legit Aficionado
Posts: 64
Joined: Tue Jul 06, 2004 2:24 pm
Location: North Carolina
Contact:

Postby Mr. Chan » Wed Jul 07, 2004 10:38 pm

sounds good, i hadnt gotten to them yet but im about to, im excited kinda bout the new temporal aa...too bad only the x800 i think can get enough fps in far cry to use it...shameful!

*EDIT* No problems so far, 4.6 made desktop sluggish, but 4.7 is good - it seems this is with every other release, lol...TAA works good on RTCW for me; Far Cry works with no texture corruption (but I'm not about to try to mess it up, heh)
P4C800-DX

P4 2.4C (2952Mhz)

Corsair 2x256MB-XMS3200C2-PT

Radeon 9600 Pro

Windows XP Professional

kalmark
Legit Aficionado
Legit Aficionado
Posts: 82
Joined: Wed May 05, 2004 2:46 pm
Location: Budapest, Hungary, Europe

Postby kalmark » Thu Jul 08, 2004 7:42 am

I have some performance problems with Americas Army with the new driver, I will have to roll it back :?

Update: no rollback or uninstall fixed this problem :evil: I dunno WTF happened, I'm just plain angry

Update: it works well in windowed mode, but not in fullscreen... :shock:
Last edited by kalmark on Thu Jul 08, 2004 3:08 pm, edited 2 times in total.
Image

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33806
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Postby Apoptosis » Thu Jul 08, 2004 8:51 am

So far so good on my 9800 Pro 256mb card... but I've only had the chance to play about 30mins on Farcry and Painkiller.

Mr. Chan
Legit Aficionado
Legit Aficionado
Posts: 64
Joined: Tue Jul 06, 2004 2:24 pm
Location: North Carolina
Contact:

Postby Mr. Chan » Thu Jul 08, 2004 5:26 pm

kalmark: im not to sure about what the rollback does entirely, maybe it was the new drivers and the rollback didnt change everything...if i thought some traces of some drivers were left for catalyst, what i would do is uninstall them/use driver cleaner for it and then try some other drivers (or test with the new ones again, etc)
P4C800-DX

P4 2.4C (2952Mhz)

Corsair 2x256MB-XMS3200C2-PT

Radeon 9600 Pro

Windows XP Professional

Mr. Chan
Legit Aficionado
Legit Aficionado
Posts: 64
Joined: Tue Jul 06, 2004 2:24 pm
Location: North Carolina
Contact:

Postby Mr. Chan » Thu Jul 08, 2004 5:46 pm

Forgot to mention, I played through the level on RTCW (forgot the name) this morning that has the Tank rolling through and you have to help escort the defecting scientist and gain access to the Secret Weapons Facility (I think that's the name of it, the SWF)...it was neat because it had the flamethrower (first level to use it) and of course, the Panzerfaust rockets and dual colt pistols :) lol...I played it with Temporal AA, 4xAA, 16xAF and everything else set to Highest quality (in-game and otherwise, including truform, but wolf doesnt want to turn truform on for some reason...I used to have it on, though...) and I maintained about 85-90FPS which was nice and it looked pretty good, too...but I can't say I tested for differences back and forth with/without TAA -- but I played fine and looked good for what it was...rtcw is aging so there's only so much you can do anyway...I suppose.

I think the real test is for the X800 on something like Far Cry or at least maybe a 9800p on Max Payne 2 might be interesting...I can't get 60FPS with all the high settings I use on my little '96 pro, lol and I like my quality :) so I can't really test a lot with TAA...but UT2004 and such should prove to be pretty with TAA as long as that 60 fps is on there...*drools*
P4C800-DX

P4 2.4C (2952Mhz)

Corsair 2x256MB-XMS3200C2-PT

Radeon 9600 Pro

Windows XP Professional

kalmark
Legit Aficionado
Legit Aficionado
Posts: 82
Joined: Wed May 05, 2004 2:46 pm
Location: Budapest, Hungary, Europe

Postby kalmark » Fri Jul 09, 2004 2:10 am

I have already done virtually everything to get rid of this choppyness...There does not seem to be a way out, sadly. Having 2 FPS sucks :evil:
Image

Mr. Chan
Legit Aficionado
Legit Aficionado
Posts: 64
Joined: Tue Jul 06, 2004 2:24 pm
Location: North Carolina
Contact:

Postby Mr. Chan » Fri Jul 09, 2004 4:35 pm

Perhaps you should try a previous version that worked...that's what I do sometimes, since ATi updates kinda, frequently now...I haven't had much difference with going back a version since 4.2 (4.2 was sluggish and I used 4.1 until 4.3 came out, then 4.6 was sluggish so I went to 4.1 and then 4.7 came out the next day!!) ...lol :)
P4C800-DX

P4 2.4C (2952Mhz)

Corsair 2x256MB-XMS3200C2-PT

Radeon 9600 Pro

Windows XP Professional

kalmark
Legit Aficionado
Legit Aficionado
Posts: 82
Joined: Wed May 05, 2004 2:46 pm
Location: Budapest, Hungary, Europe

Postby kalmark » Sat Jul 31, 2004 6:42 am

kalmark wrote:I have already done virtually everything to get rid of this choppyness...There does not seem to be a way out, sadly. Having 2 FPS sucks :evil:

Quite a bit offtopic in the 4.7 topic, but 4.8 betas helped to resolve this problem for me.
But I'm almost crying seeing my card's performance in Far Cry :( At this time I can only play at the lowest settings - serious tweaking time for me. :evil:

edit: nope, it fails again. WHYWHYWHY? :cry:
Image


Return to “AMD Radeon and FirePro Forum”

Who is online

Users browsing this forum: No registered users and 3 guests