Page 1 of 1

Network Adapter Works in Win8.1 but not Win7

Posted: Tue Apr 30, 2019 11:57 pm
by Kaos Kid
I have a weird issue. My onboard LAN network adapter (Realtek 8111E Gigabit) stopped working in Windows 7. I get the Microsoft "Code 1" even after I uninstall the adapter then try to reinstall drivers, I even pulled out the old MOBO driver disk to install the original driver, it won't install any drivers correctly from any source. At first I thought my LAN module had died, but I have Win8.1 on a dual boot (Although I never use it, I hate 8.1) and when I boot to that Win8.1 drive the network adapter installs correctly in device manager and I can get an ethernet network connection directly to the router. I have tried to find solutions but none seem to work, I'm not sure why Win7 won't play nice with the onboard LAN anymore. Is there a something else I can check to make this adapter "reset" itself to work again in Win7? I'd like to be able to keep this PC on ethernet because I use it to access my router interface, the DLink routers are vulnerable to WEB GUI so I'd rather be hardwired to the router to access it's settings.

I have tried with the ethernet cable both plugged and unplugged, and also uninstalled the wireless adapter's software and driver that I had been using in a pinch to get online to troubleshoot. Is this just a matter of something corrupted in the registry? Any idea where I would look there to access the settings pertinent to the ethernet adapter? Thanks for any insights you can give.

Re: Network Adapter Works in Win8.1 but not Win7

Posted: Wed May 01, 2019 3:09 am
by DJ Tucker
have you tried doing a windows troubleshoot as that has been known to restore unknown issues? If that doesn't work try opening device manager, highlight the network adapter and uninstall it but do not reboot as windows will default the driver that may cause the issue. Next, right click the network adapter and update driver but do not allow windows to install default, locate your own downloaded driver and install that then reboot.

If all above fails, then repeat the uninstall and do not reboot then allow windows to install the default driver. Hope this works for you :)

Re: Network Adapter Works in Win8.1 but not Win7

Posted: Wed May 01, 2019 2:33 pm
by Kaos Kid
Thanks. I have already tried uninstalling and reinstalling both with and without reboot. Sometimes it shows the ethernet controller in device manager without a yellow hazard mark and with no driver installed, and when I try to install any driver (even the one MS Update wants to install) it then gives the error that device isn't working, not configured correctly, etc. Then as I go through every driver that shows up in the list of drivers (I think past drivers) one by one, it won't accept any of them. I've had a few wifi adapters on this board as well, some using Realtek wifi drivers (like the onboard LAN uses the PCI version). I wonder if somehow I accidentally installed one of those as an ethernet driver and fubar'd something. You'd think though that after uninstall and reinstall it would accept a correct driver again. Not as fun to troubleshoot as it used to be, lol, now I just want to turn it on and have it work without hassle. I may just have to find a copy of Win10 and drag my butt into 2016, not looking forward to that though because the mobo is my ASUS M4A89GTD Pro USB3 with my 1100T and I'm not so sure it will be compatible with 10 until I try it. Not really looking forward to reinstalling Win7 either, since it would take 12 years of updates to bring me back to today and from what the nag screens have been telling me they are going to end support within a year. Is there away to clear out all the old drivers so they don't even show in the install list? Not sure where they are, I looked in system32/drivers and system32/driverstore folders and couldn't tell where they were, the only "Realtek" folder in there was empty and that was probably a leftover from using Revo Uninstaller Pro which was one of the methods I tried to clear them out but there must be some more drivers stored somewhere else that I don't know how to access to delete.

Re: Network Adapter Works in Win8.1 but not Win7

Posted: Wed May 01, 2019 3:00 pm
by DJ Tucker
you can use driver booster from iobit to clean unplugged and unused device/drivers if that's something your willing to try. I even have a key you can have for pro edition :)

Re: Network Adapter Works in Win8.1 but not Win7

Posted: Thu May 02, 2019 4:14 am
by KnightRid ... -windows-7
How to remove old device drivers in Windows 10/8/7

If you find that some of your newly installed devices are not working correctly or in fact, your Windows computer freezes frequently, you might want to consider removing old & unused device drivers in Windows 10/8/7.

remove old drivers
Remove Old Drivers on Windows PC

To remove old and unused drivers from your Windows computer, first open Start Menu and right-click on Computer and select Properties. From the left side panel, click on Advanced system settings and click on Environment Variables. Alternatively, simply open Control Panel and type Environment Variables.

Now under the User variables box, click on New and type-


in the Variable Name text box & 1 in the Variable Value box. This will set a flag to allow you to now view unused devices.

You can also use this method to show Non-present drivers.

Now type devmgmt.msc in start search and hit Enter to open the Device Manager.

Click View tab and select Show hidden devices. Expand the branches in the device tree & look for the faded icons. These indicate unused device drivers.

Right-click on it and select Uninstall.

That’s it!
If you have been through all those hardware changes I would really think of doing a fresh install or upgrading to windows 10. ... d/windows7

Re: Network Adapter Works in Win8.1 but not Win7

Posted: Fri May 03, 2019 2:42 pm
by DJ Tucker
Also forgot you can use device manager to show all hidden drivers and uninstall all the old ones that way :)