Page 1 of 1

My Mouse moves too slowly

Posted: Thu May 16, 2019 3:13 am
by Frank36
Using Lenovo tablet with Intel i7-855u Processor, 8GB RAM, Windows 10 64-bit. I don't like and don't use the touchpad. I use a wireless USB mouse. The same mouse I have used on another laptop where it runs plenty fast enough for me.

I've adjusted to the fastest possible speed in Control Panel; but the fastest is still too slow. This mouse has three kinds of speeds, too slow, much too slow and much more too slow.

What can I do?

Re: My Mouse moves too slowly

Posted: Thu May 16, 2019 3:30 am
by KnightRid
Try changing batteries. Yes, just try.

Make sure the touchpad is disabled. Had one that the mouse did not work for anything until I manually disabled the touchpad. No idea why. I think that was an Acer.

Uninstall and reinstall the mouse drivers. Uninstall - turn off - unplug mouse from computer - turn back on - after windows starts then plug mouse back in. If your touchpad is working then you can always remove the mouse before uninstalling since you will be able to restart the computer easier, or if you know how to use the keyboard to do it.

Still nothing - try a different mouse if you have one to see if it is specific to the mouse or to all mice. All mice would mean you should recheck those settings under control panel.

Re: My Mouse moves too slowly

Posted: Wed May 22, 2019 1:07 am
by marytd
You may try to update your driver then restart laptop. If not work then try to update windows and restart. I think it work for you.
Thanks

Re: My Mouse moves too slowly

Posted: Sat Jul 20, 2019 5:31 am
by franklin99
Make sure to Save it, close the touchpad utility and click OK on the Mouse Properties window.

Re: My Mouse moves too slowly

Posted: Thu Oct 31, 2019 5:02 am
by AdrianG001
Open Settings, and search for Touchpad. You can also find the Touchpad settings under Devices.
Move the slider under Change the cursor speed. The changes take effect immediately, so you can test the speed right away.



Regards,
Adrian