The Free After Rebate Ultra 500W Power Supply

A place to give your thoughts on our reviews!
Zoogle
Legit Enthusiast
Legit Enthusiast
Posts: 28
Joined: Thu Feb 15, 2007 7:59 pm

Post by Zoogle » Sun Feb 25, 2007 9:39 pm

Good to see that you can get a good deal on a reasonably good PSU. If anything, it could power a folding machine!

Vaggeto
Legit Little One
Legit Little One
Posts: 4
Joined: Tue Feb 27, 2007 9:43 pm

Post by Vaggeto » Tue Feb 27, 2007 9:52 pm

Hey there, thank you for this review!

I have Two Ultra power supplies.

Right now I have an Ultra X-Finity 500W and this FAR Ultra V 500W.

My question is which one is best for a system running:
Intel C2D E6400 overclocked. 1 HDD, 2GB ram. EVA 7900 GS.

The first test system was similar to this especially with the 7900 GS which brought up two questions.

Note: The Ultra V has 1 12V rail rated at 28A(336W). The Xfinity has 2 12V rails rated at 16A and 18A(384W).

Firstly: "First up to bat is the XFX GeForce 7900 GS video card. To run this card it is suggested that you have a 350W power supply with 12V rating of 20A or more."

I was going to use the Xfinity due to it have higher 12v rails overall. But none are rated above 20A? Does the fact that they're seperated matter much? Am I going to have to use the Ultra V instead?

Secondly: Are either of these two PSus strong enough for a system like this?

Thank you very much, I appreciate your help!

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33922
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Post by Apoptosis » Tue Feb 27, 2007 10:36 pm

Vaggeto,

To be honest both should work fine and I suggest trying them both and seeing which one has the best looking voltage rails to you. You can check this in the BIOS or with software or a volt meter like I did!

Cheers!

Vaggeto
Legit Little One
Legit Little One
Posts: 4
Joined: Tue Feb 27, 2007 9:43 pm

Post by Vaggeto » Tue Feb 27, 2007 10:49 pm

Thanks for the quick reply. So you don't think the whole 20A 12V rail will matter with the 7900 GS? When it says you should have that, does it mean total amps or at least one 12v with that much? I think the X-Finity is the better PSU so I'd like to use it, I just don't want that to be an issue.

Thanks and I guess you're right, it can't hurt trying both and testing... Just will have to wait for the MB, and videocard... and figure out the ram!

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33922
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Post by Apoptosis » Tue Feb 27, 2007 10:54 pm

Many power supplies have multiple +12V rails and just because the rails are 'low' it doesn't mean your hardware wont have enough juice. If a power supply has four +12V rails at 18Amps each they route them to feed different things. Like +12v1 might be for the mobo only, +12v2 is for the 4-pin molex connectors, +12v3 is for the PCIe headers and +12v is for the SATA drives. No worries at all!

oh and it means total Amps...

Vaggeto
Legit Little One
Legit Little One
Posts: 4
Joined: Tue Feb 27, 2007 9:43 pm

Post by Vaggeto » Tue Feb 27, 2007 11:36 pm

Ahhh, sounds good. Thank you very much!

Zenphic
Legit Fanatic
Legit Fanatic
Posts: 179
Joined: Mon Jun 05, 2006 4:13 pm
Location: Quebec, Canada

Post by Zenphic » Wed Feb 28, 2007 5:52 pm

Ahhhhh, I can't believe I missed this deal to get a free power supply! I was already depressed on how I missed the last deal a year ago or so at RadioShack, now again! Dorgh!

Nice review though Apoptosis. Any comments on it's noise? Or is it relatively quiet?

User avatar
DaIceMan
Legit Extremist
Legit Extremist
Posts: 1599
Joined: Tue Jul 18, 2006 10:31 pm
Location: Springfield-ish, Missouri
Contact:

Post by DaIceMan » Thu Mar 01, 2007 11:46 pm

werty316 wrote:Isn't it just styrofoam?

That is quite risky using a PSU that meets the bare minimum of a 8800GTX as you still have to account everything else connected to it.
Don't worry... the GTX can take care of itself. If it isn't getting sufficient power, it will give you an alert (in the form of a pop up in the middle of your screen) stating that the GPU isn't receiving sufficient power and is running at a lowered rate to prevent damage... or something to that effect. I had this come up with my Silverstone power supply *cough* POS *cough* that I bought for my new rig wouldn't power my GTX.

jonnyGURU
Legit User
Legit User
Posts: 21
Joined: Fri May 26, 2006 9:27 am
Location: Lake County, IL
Contact:

Post by jonnyGURU » Sat Mar 03, 2007 7:48 am

Zenphic wrote:Ahhhhh, I can't believe I missed this deal to get a free power supply! I was already depressed on how I missed the last deal a year ago or so at RadioShack, now again! Dorgh!
The deal gets "rotated."

Just keep your eyes peeled at the usual suspects like Rat Shack, Fry's, Tigger, MicroCenter and ZZF and they're bound to have an FAR V-Series some week.

Landon
Legit User
Legit User
Posts: 16
Joined: Sun Mar 04, 2007 5:28 pm
Location: Mobile, AL

Receiving Rebate

Post by Landon » Sun Mar 04, 2007 5:40 pm

Apoptosis,
I read you article concerning the Ultra "free" power supply and was impressed. Also, was wondering if you've got your rebate back or checked the status at http://rebate-zone.com/default.asp?PN=U00138 to see if they have any info on the rebate? I did, and it said there was no record of a rebate for me. Curious.

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33922
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Post by Apoptosis » Sun Mar 04, 2007 7:07 pm

Ultra Products, Inc

Search Results:
Results: Claim Not Found

For further assistance please call (866) 871-4973
Nothing on me either and I sent mine in on Feb 20, 2007... I am keeping my eye on this and will be updating the article or writing a new one if things go south.

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33922
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Post by Apoptosis » Sat Mar 10, 2007 5:16 pm

still nothing on mine :(

Landon
Legit User
Legit User
Posts: 16
Joined: Sun Mar 04, 2007 5:28 pm
Location: Mobile, AL

Post by Landon » Thu Mar 15, 2007 4:53 pm

Still nothing on this end either!
Could make you wonder if this is a scam to get rid of those 500 watt Ultra Power Supplys.

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33922
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Post by Apoptosis » Sun Mar 18, 2007 8:31 am

yeah it's been a almost a month and it's not even in the system yet... This is an example of why rebates suck.

T-Shirt
Legit Extremist
Legit Extremist
Posts: 589
Joined: Wed May 05, 2004 3:27 pm
Location: Snohomish, WA USA

Post by T-Shirt » Sun Mar 18, 2007 9:47 am

I believe Ultra is a division of Systemax Inc (ie Tiger direct, Global computer, etc.)
If the rebates are like Tiger direct's you will get it eventually, but their system is extremely slow with checks and updates coming weeks or months late.

User avatar
dicecca112
Site Admin
Site Admin
Posts: 5013
Joined: Mon Mar 01, 2004 10:40 am
Contact:

Post by dicecca112 » Sun Mar 18, 2007 10:04 am

well that'd be wrong. And Tigerdirect since there rebate scandal has had an outside company handle there rebates and from what I've heard are really good now
Image

Landon
Legit User
Legit User
Posts: 16
Joined: Sun Mar 04, 2007 5:28 pm
Location: Mobile, AL

Post by Landon » Sun Mar 18, 2007 11:10 pm

If you want another "free" item check out this site for a free computer case after rebate. Includes free shipping.
http://shop3.outpost.com/product/5124886

I would try it if as you can see from above I haven't got my rebate for the free power supply yet nor they said they haven't received it. Maybe if it comes before this deal run out I will try it.

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33922
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Post by Apoptosis » Mon Mar 19, 2007 6:56 am

agreed... waiting too

FTLOSM
Legit User
Legit User
Posts: 9
Joined: Fri Mar 23, 2007 11:12 am
Location: MI

I have this and have a few questions...

Post by FTLOSM » Fri Mar 23, 2007 11:26 am

I have this very same power supply, got the deal on frys $40 with $40 rebate, bought it in nov 06, just got the rebate this week March 07 not sooo bad, anyways i just installed a video card from MSI that had this pc check program, i ran it and it gave me warning messages about my power supply, i then downloaded speedfan and it is showing what appears to be funky readings but again I am not sure on this so am asking here...

This is what speedfan says

Vcore1 1.62
Vcore2 2.48
+3.3v 3.23v
+5v 3.41v ????
+12v 12.29v

-12v -1.16v ???? not a misprint this seems very off...
-5v -1.09v ?????
+5v 2.18v ?????
Vbat 0.00v ?????

This just seems odd to me, the MSI program keeps trying to turn the pc off! Speed fan reports those numbers above, starting to have a weird feeling my free power supply might be a bad one, but the pc has worked fine no issues or anything so its making me wonder....

Here is my setup,
antec 1080 full tower case, 5 pc fans, 1 7200rpm 160 gig hd, 2 cdrom/dvdburners, floppy, MSI nx6200 T256 video card, amd athlon throughbred 3000 processor, 1 gig of ram, on a gigabyte motherboard, nothing overclocked or souped up, fans going keepin things cool, no hardcore gaming or anything normal pc use, just curious is this ps bad or are these readings normal to see (seem way out of range to me) I did call Ultra sat on hold hung up and sent an email but no reply yet...

I guess I never would have known this if i didnt install that tiny msi pc check program, then as I dug around the net i installed speedfan as a secondary check which confirmed something is goofy here i think...

anything i can check or do or have i just got a lemon ps here...

The powersupply didnt even fit into my case, it seems too small, i have a antec 1080 full tower i did install it but there is a gap on one side, thought it would fill the hole and replace my old antec truepower that did die on me (smoked) had to get new motherboard and everything...ughh

Thanks for any input on these questions about this power supply, curious what others have to say after a few months use like myself, i never would have known these readings if i didnt install that tiny pc app from msi, now im freakin out a bit here...or am I just over reacting....

Bill

FTLOSM
Legit User
Legit User
Posts: 9
Joined: Fri Mar 23, 2007 11:12 am
Location: MI

Post by FTLOSM » Fri Mar 23, 2007 12:57 pm

Just got a reply from ultra via email zapped them a jpg of my invoice name phone addy etc and supposedly they will reply with return information to get a new one.

Not even sure if it is worth the $$ to ship this one back at my expense but at this point I am even (paid for it got it free) so maybe $5 to send it back in hopes a good one comes will be worth it...

Bill

Post Reply