Far Cry 2 Lag!

A place to rant and rave about all the current gaming titles!
Post Reply
User avatar
DJ Tucker
Legit Extremist
Legit Extremist
Posts: 1189
Joined: Tue Dec 30, 2008 11:52 am
Location: Hardbase Headquaters
Contact:

Far Cry 2 Lag!

Post by DJ Tucker » Wed Aug 24, 2011 2:22 pm

i have a problem that has just recently started. i can play fine with all settings on high on DX10 and have 50fps average so playable by all means but for some reason and only the last 2 days when i in a vehical the games run again at 50fps average but as soon as i get out of the vehical it lags to 15fps average i mean what the hell and it does this all the time even closing the game and starting it back up does nothing to the lag. so on foot i get 15fps with 85% gpu usage and in vehical 55fps 55% gpu usage? any help :)
Armageddon V1.0
Processor: Core i7 9700k 4.9Ghz (AVX 4.9Ghz) @ 1.264v Barrow 240mm+360mm
Memory: 16Gb Corsair Vengeance LED 2700Mhz 16-16-16-32-1T
Hard Drive: Silicon Power P32A80 128Gb & Intel 660p 2Tb
Video Card: RTX 2070 Heatkiller IV 2010Mhz @ 0.975v
Power Supply: Corsair HX1000i
Monitor: Lenovo L24Q-10 1440P
OS: Windows 10 64 bit Pro
Mobo: ASRock Z390 Phantom Gaming 6
Case: Vector VDM01
Peripherals: K70 Lux, M65 Pro, and Void Pro Wireless

User avatar
Major_A
Legit Extremist
Legit Extremist
Posts: 3793
Joined: Tue May 15, 2007 2:11 pm
Location: Houston, TX

Re: Far Cry 2 Lag!

Post by Major_A » Sun Aug 28, 2011 2:24 am

Probably has to do with the foliage rendering. I imagine that the game detects you're in a vehicle so it doesn't make the grass and tress as detailed. But when you're out walking around it is.

Other than that I'd say make sure you're running the latest drivers from nVidia.

User avatar
DJ Tucker
Legit Extremist
Legit Extremist
Posts: 1189
Joined: Tue Dec 30, 2008 11:52 am
Location: Hardbase Headquaters
Contact:

Re: Far Cry 2 Lag!

Post by DJ Tucker » Tue Aug 30, 2011 6:33 am

it's still doing the same but when i get out of the vehical the game runs fine for 5-10 mins then suddenly it lags for no reason. as soon as i get back in the car/jeep it's fine again :( already got the latest nvidia drivers 280.26 :)
Armageddon V1.0
Processor: Core i7 9700k 4.9Ghz (AVX 4.9Ghz) @ 1.264v Barrow 240mm+360mm
Memory: 16Gb Corsair Vengeance LED 2700Mhz 16-16-16-32-1T
Hard Drive: Silicon Power P32A80 128Gb & Intel 660p 2Tb
Video Card: RTX 2070 Heatkiller IV 2010Mhz @ 0.975v
Power Supply: Corsair HX1000i
Monitor: Lenovo L24Q-10 1440P
OS: Windows 10 64 bit Pro
Mobo: ASRock Z390 Phantom Gaming 6
Case: Vector VDM01
Peripherals: K70 Lux, M65 Pro, and Void Pro Wireless

User avatar
Major_A
Legit Extremist
Legit Extremist
Posts: 3793
Joined: Tue May 15, 2007 2:11 pm
Location: Houston, TX

Re: Far Cry 2 Lag!

Post by Major_A » Tue Aug 30, 2011 9:08 pm

You running all the patches for the game?
http://www.gamefront.com/files/listing/ ... al_Patches

You also might try turning down the view distance, texture resolution and foliage density. I know it won't look as good but this could help narrow down the problem. If I recall correctly (probably wrong) but SLI video cards don't combine the video cards memory. So you might only have 512MB available for the game to use. The stuttering might be filling up the memory buffer.

User avatar
Major_A
Legit Extremist
Legit Extremist
Posts: 3793
Joined: Tue May 15, 2007 2:11 pm
Location: Houston, TX

Re: Far Cry 2 Lag!

Post by Major_A » Wed Aug 31, 2011 11:27 am

I just reinstalled Far Cry 2 last night. What are your in game settings? Post a screenshot of the benchmark tool video options.

Image

User avatar
DJ Tucker
Legit Extremist
Legit Extremist
Posts: 1189
Joined: Tue Dec 30, 2008 11:52 am
Location: Hardbase Headquaters
Contact:

Re: Far Cry 2 Lag!

Post by DJ Tucker » Thu Sep 01, 2011 3:51 am

I have run the benchmark with this setting and get an average of 40fps with min at 28fps and high at 75fps but not the 15fps i was getting. so i went into game thinking that maybe it's fixed and after 5-10 mins it lagged out at 15fps again and i only using 467mb of my gpu's and i have the latest patch :(

Image
Armageddon V1.0
Processor: Core i7 9700k 4.9Ghz (AVX 4.9Ghz) @ 1.264v Barrow 240mm+360mm
Memory: 16Gb Corsair Vengeance LED 2700Mhz 16-16-16-32-1T
Hard Drive: Silicon Power P32A80 128Gb & Intel 660p 2Tb
Video Card: RTX 2070 Heatkiller IV 2010Mhz @ 0.975v
Power Supply: Corsair HX1000i
Monitor: Lenovo L24Q-10 1440P
OS: Windows 10 64 bit Pro
Mobo: ASRock Z390 Phantom Gaming 6
Case: Vector VDM01
Peripherals: K70 Lux, M65 Pro, and Void Pro Wireless

User avatar
Major_A
Legit Extremist
Legit Extremist
Posts: 3793
Joined: Tue May 15, 2007 2:11 pm
Location: Houston, TX

Re: Far Cry 2 Lag!

Post by Major_A » Thu Sep 01, 2011 7:11 pm

Hmm... did you run the Ranch Long Map (or whatever it's called)? Another thing to check is the Intel features in the BIOS. Do you have Speedstep or any of the other throttling features turned on?

Try this and see if it helps, if not you can always change it back. Run your system RAM at 5-6-6-18-24 2T and adjust the voltage to at least 2.0V in the BIOS. Don't go any higher than 2.2V unless you have a fan sitting on it. Sometimes stuttering issues with games/apps is with the RAM.

User avatar
DJ Tucker
Legit Extremist
Legit Extremist
Posts: 1189
Joined: Tue Dec 30, 2008 11:52 am
Location: Hardbase Headquaters
Contact:

Re: Far Cry 2 Lag!

Post by DJ Tucker » Fri Sep 02, 2011 10:24 am

no luck however the problem seems to have fixed itself well it stuuters for 1-2 mins once or twice but then stops completey. strange :shock:
Armageddon V1.0
Processor: Core i7 9700k 4.9Ghz (AVX 4.9Ghz) @ 1.264v Barrow 240mm+360mm
Memory: 16Gb Corsair Vengeance LED 2700Mhz 16-16-16-32-1T
Hard Drive: Silicon Power P32A80 128Gb & Intel 660p 2Tb
Video Card: RTX 2070 Heatkiller IV 2010Mhz @ 0.975v
Power Supply: Corsair HX1000i
Monitor: Lenovo L24Q-10 1440P
OS: Windows 10 64 bit Pro
Mobo: ASRock Z390 Phantom Gaming 6
Case: Vector VDM01
Peripherals: K70 Lux, M65 Pro, and Void Pro Wireless

User avatar
Major_A
Legit Extremist
Legit Extremist
Posts: 3793
Joined: Tue May 15, 2007 2:11 pm
Location: Houston, TX

Re: Far Cry 2 Lag!

Post by Major_A » Fri Sep 02, 2011 10:30 am

Have you looked on Ubisoft's forums? Might we worth creating an account so you can search and see if there's a solution. Did you change any hardware settings when it stopped or did it seem to fix on it's own?

User avatar
DJ Tucker
Legit Extremist
Legit Extremist
Posts: 1189
Joined: Tue Dec 30, 2008 11:52 am
Location: Hardbase Headquaters
Contact:

Re: Far Cry 2 Lag!

Post by DJ Tucker » Fri Sep 02, 2011 5:16 pm

fix on it's own. bizarre :)
Armageddon V1.0
Processor: Core i7 9700k 4.9Ghz (AVX 4.9Ghz) @ 1.264v Barrow 240mm+360mm
Memory: 16Gb Corsair Vengeance LED 2700Mhz 16-16-16-32-1T
Hard Drive: Silicon Power P32A80 128Gb & Intel 660p 2Tb
Video Card: RTX 2070 Heatkiller IV 2010Mhz @ 0.975v
Power Supply: Corsair HX1000i
Monitor: Lenovo L24Q-10 1440P
OS: Windows 10 64 bit Pro
Mobo: ASRock Z390 Phantom Gaming 6
Case: Vector VDM01
Peripherals: K70 Lux, M65 Pro, and Void Pro Wireless

Post Reply