Global Proxy In Xubuntu

Operating Systems
Windows, Linux, Solaris, Red Hat, etc.....32 bit or 64 bit.
If its an OS, its here.
Post Reply
User avatar
DMB2000uk
Site Admin
Site Admin
Posts: 7095
Joined: Mon Jul 18, 2005 5:36 pm
Location: UK

Global Proxy In Xubuntu

Post by DMB2000uk » Mon Oct 13, 2008 1:16 pm

There isn't a system menu like in Ubuntu, so I can't add it there.

What's the fix/tweak/hack to set it via other means?

Dan
Image (<- Clickable)

User avatar
dicecca112
Site Admin
Site Admin
Posts: 5014
Joined: Mon Mar 01, 2004 10:40 am
Contact:

Re: Global Proxy In Xubuntu

Post by dicecca112 » Mon Oct 13, 2008 1:44 pm

Image

User avatar
DMB2000uk
Site Admin
Site Admin
Posts: 7095
Joined: Mon Jul 18, 2005 5:36 pm
Location: UK

Re: Global Proxy In Xubuntu

Post by DMB2000uk » Mon Oct 13, 2008 2:27 pm

Saw both those threads earlier today, and did try this:
Here's what worked for me.
Add the following line to /etc/environment :
Code:

http_proxy="http://user:[email protected]:port"
But it didn't do anything, I can't remember if i rebooted though or not, so will have to check again tomorrow (the machine is at work).
Accessories>Appfinder
and Network Proxy is in the list of applications.
Couldn't find that, they must have removed it. :(

Dan
Image (<- Clickable)

User avatar
DMB2000uk
Site Admin
Site Admin
Posts: 7095
Joined: Mon Jul 18, 2005 5:36 pm
Location: UK

Re: Global Proxy In Xubuntu

Post by DMB2000uk » Tue Oct 14, 2008 3:53 am

Well despite those links saying that the export of proxy in the terminal would only be good for the console they were in, it seems that it has applied it system wide and updates and additional programs/packages are now working.

Thanks Matt and Kyle,

Dan
Image (<- Clickable)

User avatar
Alathald
Legit Extremist
Legit Extremist
Posts: 1630
Joined: Sun Dec 17, 2006 11:55 pm
Location: Southern Ohio
Contact:

Re: Global Proxy In Xubuntu

Post by Alathald » Tue Oct 14, 2008 4:50 am

NP if it doesn't stick after a reboot stick the export http_proxy="http://[proxy]@[port]" in your /etc/rc.local and that command will be run every startup. If it still works after a reboot though just ignore me :P
Image

User avatar
Alathald
Legit Extremist
Legit Extremist
Posts: 1630
Joined: Sun Dec 17, 2006 11:55 pm
Location: Southern Ohio
Contact:

Re: Global Proxy In Xubuntu

Post by Alathald » Tue Oct 14, 2008 4:40 pm

I'm a dolt...run sudo gnome-network-preferences from the terminal. It even has a GUI :P
Image

User avatar
DMB2000uk
Site Admin
Site Admin
Posts: 7095
Joined: Mon Jul 18, 2005 5:36 pm
Location: UK

Re: Global Proxy In Xubuntu

Post by DMB2000uk » Wed Oct 15, 2008 3:08 am

Well it didn't stick after the reboot so I had to export the proxy in the terminal then, apt-get install gnome-network-preferences, but that installed and worked a treat.

Thanks Kyle. :mrgreen:

Dan
Image (<- Clickable)

John_M
Legit Little One
Legit Little One
Posts: 1
Joined: Wed Dec 16, 2009 7:19 am

Re: Global Proxy In Xubuntu

Post by John_M » Wed Dec 16, 2009 7:37 am

I know this is a bit late, but perhaps it will help someone with Xubuntu's proxy settings. I'm using 9.10 now.

In order to set a global proxy, you need to edit the following files:

I use mc (Midnight Commander) to do this.
Install mc by using:

Code: Select all

sudo apt-get install mc
Then, sudo mc, to browse to and edit the files.

The first file to edit is:
/etc/apt/apt.conf

You should add a line similar to this one. It depends on your proxy server address.
Acquire::http::Proxy "http://192.168.0.1:3128/";

This will allow synaptic to work properly.

In order for wget to work, you need to edit:
/etc/wgetrc

About 1/3 way down, remove the #s and change
the address to your proxy server address.

# You can set the default proxies for Wget to use for http and ftp.
# They will override the value in the environment.
http_proxy = http://192.168.0.1:3128/
ftp_proxy = http://192.168.0.1:3128/

# If you do not want to use proxy at all, set this to off.
use_proxy = on

I hope this helps!!!

John

Post Reply