battery wont charge

A place to talk about all things mobile
Post Reply
User avatar
smack323
Legit Extremist
Legit Extremist
Posts: 1271
Joined: Fri Dec 30, 2005 4:28 pm
Location: Waukesha, WI

battery wont charge

Post by smack323 » Wed Nov 18, 2009 6:50 pm

I have never really used a laptop before. I was given one buy a friend she told me it was broken. the battery wont charge. I bought a new battery to replace the old one thinking that was the problem - but when i plug in the power cord it initally starts charging for a minute or so then it stops. i googeled the problem for this model laptop and some people had luck updating the bios. I tried that and now i also lost the wireless adaptor. I installed windows 7, and they didnt have any bios that supported 7 so i uses a Vista bios. i am not sure why this would cause the wireless to not work. Does anyone with more experiance with laptops have any tricks to get the battery to charge? I assume I can roll back the bios somehow to get the wireless working.
Core i5-6500 - Corsair Vengence 16GB DDR4 2133 - Asus GTX 1070 DUAL 8GB - Antec 750W - Crucial 525GB SSD - Windows 10 64bit - ASUS 27" LED

User avatar
Sporg
Legit Extremist
Legit Extremist
Posts: 1200
Joined: Mon Dec 11, 2006 10:22 am
Location: Kansas City Area
Contact:

Re: battery wont charge

Post by Sporg » Wed Nov 18, 2009 9:29 pm

So as far as "power" is concerned, the only thing it does not do is charge the battery, correct? Could you share make and model of the laptop?
I would never die for my beliefs because I might be wrong.
~Bertrand Russell

User avatar
smack323
Legit Extremist
Legit Extremist
Posts: 1271
Joined: Fri Dec 30, 2005 4:28 pm
Location: Waukesha, WI

Re: battery wont charge

Post by smack323 » Sat Nov 21, 2009 5:49 pm

correct- wont charge the battery for more than a minute.. ill post the model when i get home.
Core i5-6500 - Corsair Vengence 16GB DDR4 2133 - Asus GTX 1070 DUAL 8GB - Antec 750W - Crucial 525GB SSD - Windows 10 64bit - ASUS 27" LED

User avatar
smack323
Legit Extremist
Legit Extremist
Posts: 1271
Joined: Fri Dec 30, 2005 4:28 pm
Location: Waukesha, WI

Re: battery wont charge

Post by smack323 » Tue Nov 24, 2009 4:33 pm

ok the model is toshiba m105-s3041
for some reason it was working yesterday for about two hours. I plugged it in and it charged the battery to 100% - i unplugged it let it run down a bit plugged it back in and it said it was charging for about 30 seconds. then it went to "plugged in - not charging" like it was doing before. I tried to plug it in a few times and it would keep charging. I replaced the battery so i dont think that is the problem. the cord seems fine because when i plug it in it works fine for a bit- even when it stops charging it still shows its plugged in. what sucks is that it still drains battery when its plugged in also.

oh yeah i also updated to the newest Bios for that model also. and i was able to get the wi-fi working again also
Core i5-6500 - Corsair Vengence 16GB DDR4 2133 - Asus GTX 1070 DUAL 8GB - Antec 750W - Crucial 525GB SSD - Windows 10 64bit - ASUS 27" LED

Post Reply