Stuttering/lagging BIOS on ASUS Prime B450-A

Discussion about AMD CPU Motherboards
Post Reply
User avatar
stopthekilling77
Legit Extremist
Legit Extremist
Posts: 2188
Joined: Fri Feb 02, 2007 2:08 pm
Location: Colorado, USA

Stuttering/lagging BIOS on ASUS Prime B450-A

Post by stopthekilling77 » Mon Jul 13, 2020 3:47 pm

Hey all!

Long time, no postie, but I've got a weird issue I'm relatively certain is related to the mid-range motherboard my system came with. I caved and retired the old rig I'd kept rebuilt in my Antec P-180B and snagged a great deal on a middle of the road Cyberpower rig from Best Buy, with some minor upgrades like heatsink/fan, more RAM and larger storage options. It runs great within windows, and it's really only within the BIOS that I have any issues.

When I first got the system, the BIOS would load quickly and the keyboard/mouse performance was within the expected range for modern systems. I've updated the BIOS to the latest version and I really don't recall if it increased the time to get into the BIOS from pressing F2/DEL. I've abandoned using the mouse now that it has become an issue, and I want to know if anyone with a Ryzen 5 system is having similar issues and if there's a fix besides clearing the BIOS as I've done that recently. It may just be a janky BIOS version, but I'm not sure.

Thanks in advance!
Cyberpower special rig
ASUS Prime 450M-A
Ryzen 5 3600 stock
CM Hyper 212 EVO push/pull
24GB DDR4 3000 (soon to be 32GB)
AMD RX 580 8GB
Samsung 970 EVO Plus 500GB NVMe SSD
Lexar 256GB SSD
6GB Seagate hdd
Stock PSU (will upgrade)
ASUS VE278 27" monitor, Samsung Vizio V435-G0 42" 4K TV
Logitech Z533 2.1 Speakers, G935 7.1 headset
MS LXM-00001 Ergonomic kbd
Razer Deathadder Elite, XBOX One wireless controller

I've come a long way from that original Core2Duo build y'all! :supz:

User avatar
stopthekilling77
Legit Extremist
Legit Extremist
Posts: 2188
Joined: Fri Feb 02, 2007 2:08 pm
Location: Colorado, USA

Re: Stuttering/lagging BIOS on ASUS Prime B450-A

Post by stopthekilling77 » Mon Jul 13, 2020 11:28 pm

#-o found the culprit. My Logitech C920 has bit the dust after 7 years of faithful service. Didn't have any issues in Windows at first, then my eject USB icon went haywire. Thanks for reading.
Cyberpower special rig
ASUS Prime 450M-A
Ryzen 5 3600 stock
CM Hyper 212 EVO push/pull
24GB DDR4 3000 (soon to be 32GB)
AMD RX 580 8GB
Samsung 970 EVO Plus 500GB NVMe SSD
Lexar 256GB SSD
6GB Seagate hdd
Stock PSU (will upgrade)
ASUS VE278 27" monitor, Samsung Vizio V435-G0 42" 4K TV
Logitech Z533 2.1 Speakers, G935 7.1 headset
MS LXM-00001 Ergonomic kbd
Razer Deathadder Elite, XBOX One wireless controller

I've come a long way from that original Core2Duo build y'all! :supz:

User avatar
KnightRid
Moderator
Moderator
Posts: 4030
Joined: Wed Dec 14, 2005 5:21 am
Location: Dallastown, PA

Re: Stuttering/lagging BIOS on ASUS Prime B450-A

Post by KnightRid » Tue Jul 14, 2020 3:06 am

I would suggest looking at the C920 as the problem....... 8-[

LOL - glad you stopped by and that you got it figured out
Cigar Blog I review for - http://www.stogiereview.com

Remember, I am opinionated and nothing I say or do reflects on anyone or anything else but me :finga:

Post Reply