Intel D975XBX2 problems

Discussion about Intel CPU Motherboards

Do you have problems with your mouse?

yes (connected at USB)
2
5%
yes (connected at PS/2)
2
5%
yes (problems on both, USB and PS/2)
3
8%
no (connected at USB)
24
60%
no (connected at PS/2)
9
23%
 
Total votes: 40

User avatar
Sporg
Legit Extremist
Legit Extremist
Posts: 1200
Joined: Mon Dec 11, 2006 10:22 am
Location: Kansas City Area
Contact:

Post by Sporg » Wed Jan 03, 2007 2:08 pm

Yah, maybe that's more true.
I would never die for my beliefs because I might be wrong.
~Bertrand Russell

User avatar
jtm55
Legit Fanatic
Legit Fanatic
Posts: 140
Joined: Sun Apr 10, 2005 9:01 pm
Location: Long Island NY

Post by jtm55 » Wed Jan 03, 2007 2:37 pm

Hi All,

Yes unfortunately we the Consumer are having more & more substandard products pushed off on us.

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33922
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Post by Apoptosis » Wed Jan 03, 2007 2:56 pm

Dandruff wrote:but i agree. such things are inacceptable. but it's normal these days. the user is the beta tester ...
Very sad and very true... I've seen a bunch of companies release new products lately and never tried it out on board that consumers are using their products on. Memory is a prime example of this. With memory reaching 1000MHz+ you'd think they would test it on a board, but one company didn't even have a 680i SLI motherboard and launches a part that does well over 1000MHz... Silly what is done.

mikenj
Legit User
Legit User
Posts: 7
Joined: Tue Jan 02, 2007 6:58 pm

got new board from intel

Post by mikenj » Wed Jan 03, 2007 11:15 pm

If you check page 3 you can read all about my troubles with this board.

After a week of frustrations, I finally broke down and called intel last week. Was actually nice to get a human on the phone within 90 seconds (try that with dell!)

They went thru some basics with me, listened to my story, and quickly rma'd the board. I just got it back today, screwed it in, and voila! one of the xp installs I had hanging off the marvell controller booted right up.

Needless to say I am wiping everything clean and starting over (for the last time hopefully). Just wanted to share and make folks aware that there may be issues with some boards that cannot be surmounted by bios upgrades and such.

Never fun to deal with these type issues, but I am quite pleased with the Intel response. :drinkers:

mikenj
Legit User
Legit User
Posts: 7
Joined: Tue Jan 02, 2007 6:58 pm

Post by mikenj » Thu Jan 04, 2007 12:25 am

Well spoke too soon :evil:

complete install, format disks slow, same problems. Maybe the intel controller? It did boot on the marvell install I had. Oh well.. onto asus 8)

Dandruff
Legit Fanatic
Legit Fanatic
Posts: 174
Joined: Fri Dec 29, 2006 11:25 pm

Post by Dandruff » Thu Jan 04, 2007 12:28 am

either it's a certain bios-setting (post them here!) or this freakin old matrox card (or the drivers windows loads for it)!!!

User avatar
Sporg
Legit Extremist
Legit Extremist
Posts: 1200
Joined: Mon Dec 11, 2006 10:22 am
Location: Kansas City Area
Contact:

Post by Sporg » Thu Jan 04, 2007 10:47 am

Egg is sending me a new board today, hopefully I get it early next week. If everything works I'll post the BIOS settings, version and such.
I would never die for my beliefs because I might be wrong.
~Bertrand Russell

User avatar
jtm55
Legit Fanatic
Legit Fanatic
Posts: 140
Joined: Sun Apr 10, 2005 9:01 pm
Location: Long Island NY

Post by jtm55 » Thu Jan 04, 2007 5:06 pm

Hi All,

Maybe I spoke to soon as to my problems with my system, as Windows hung up at the splash screen. I'm not sure if this is a random thing or not. However, given all the blood & thunder I've gone through with this board, I thinkl I'll be moving over to the Asus board. I mean enough is enough.

mikenj
Legit User
Legit User
Posts: 7
Joined: Tue Jan 02, 2007 6:58 pm

Post by mikenj » Sat Jan 06, 2007 7:21 am

ok I have another board on order. Hopefully this xbx2 will work on some future bios release. Meanwhile I keep playing with it while I wait 8)

So I now have a new graphics card ASUS EN7600GS (to eliminate the old crappy matrox :rolleyes: )

still I cannot get past windows splash screen. gets about 15 seconds in and hangs. tried an installation on one drive hanging of the intel controller, then tried an installation with one drive hanging of the marvell.

what is funny is that I can boot safe mode, but not safemode with networking. So I went in and disabled the network hardware in bios, along with every other non essential piece. booted safe mode, used msconfig to configure for minimal drivers and proceessing. Then tried full boot, still the same result. bizzare!

Dandruff
Legit Fanatic
Legit Fanatic
Posts: 174
Joined: Fri Dec 29, 2006 11:25 pm

Post by Dandruff » Mon Jan 08, 2007 9:46 am

Apoptosis wrote:Welcome to the forums... Intel has confirmed and told me that a new BIOS with the Marvel controller fix should be slated for release on January 8th, 2007. My best advice is to wait till this BIOS comes out... It's less than 10 days away.
today is the day?

User avatar
jtm55
Legit Fanatic
Legit Fanatic
Posts: 140
Joined: Sun Apr 10, 2005 9:01 pm
Location: Long Island NY

Post by jtm55 » Mon Jan 08, 2007 4:08 pm

Hi All,

I've checked the Intel site & but was unable to find any new updates for the BIOS or the Marvell chipset.

progolf
Legit User
Legit User
Posts: 16
Joined: Wed Nov 22, 2006 8:15 pm

Post by progolf » Thu Jan 11, 2007 7:15 am

Today is the day that came and went :? I will wait a couple more days for the BIOS fix then I will go with ASUS.... Looking at the P5WD2-E Premium Any comments on this mobo?

Dandruff
Legit Fanatic
Legit Fanatic
Posts: 174
Joined: Fri Dec 29, 2006 11:25 pm

Post by Dandruff » Thu Jan 11, 2007 7:20 am

progolf wrote:I will wait a couple more days for the BIOS fix
seems we have to wait about a month for the next bios: http://www.abxzone.com/forums/intel-chi ... ost1349337

progolf
Legit User
Legit User
Posts: 16
Joined: Wed Nov 22, 2006 8:15 pm

seems we have to wait about a month for the next bios:

Post by progolf » Thu Jan 11, 2007 7:31 am

Apoptosis is this true?

User avatar
jtm55
Legit Fanatic
Legit Fanatic
Posts: 140
Joined: Sun Apr 10, 2005 9:01 pm
Location: Long Island NY

Post by jtm55 » Thu Jan 11, 2007 9:12 am

Hi All,

I'm going to bite the bullet & purchase one of Asus's 975 boards. However, I'm going to contact Intel, & ask for a Manufacturers refund. In truth Intel never should've released this board in the first place given all the problems that have been documented. In addition Intel has been slow to fix these problems.

mikenj
Legit User
Legit User
Posts: 7
Joined: Tue Jan 02, 2007 6:58 pm

Post by mikenj » Thu Jan 11, 2007 5:25 pm

Hey jtm55 -

I just received my p5w Dh. I also got a couple of 80gb sata drives for kicks and tried to install xp one last time on the xbx2. All symptoms the same - installs, can boot safe mode, full boot hangs at splash screen.

I am going over the notes on preparing the p5w. It is really the only thing besides the case that I have not tried to change. I will let you know how it goes in a day or two...

User avatar
Apoptosis
Site Admin
Site Admin
Posts: 33922
Joined: Sun Oct 05, 2003 8:45 pm
Location: St. Louis, Missouri
Contact:

Re: seems we have to wait about a month for the next bios:

Post by Apoptosis » Thu Jan 11, 2007 5:45 pm

progolf wrote:Apoptosis is this true?
Sorry for the delayed responses... I just returned from CES and pinged the BIOS team a few minutes ago... Not sure wtf is going on to be honest...

I got this response back:
Welcome back. I bet you are exhausted. I’m checking with BIOS manager now, and will give you an update.

User avatar
jtm55
Legit Fanatic
Legit Fanatic
Posts: 140
Joined: Sun Apr 10, 2005 9:01 pm
Location: Long Island NY

Post by jtm55 » Thu Jan 11, 2007 6:02 pm

Hi All,

Mikenj, I just ordered my Asus Board from the Egg. I too will let eveyone know how things go once I get it. Good Luck on your install.

progolf
Legit User
Legit User
Posts: 16
Joined: Wed Nov 22, 2006 8:15 pm

Post by progolf » Fri Jan 12, 2007 10:39 am

Well folks, I did it. I went out and bought the ASUS P5WD DH Deluxe and I am completely satisfied. Inter had the decency to refund me all my money for the D975XBXS so I guess I will be seeing you all in the ASUS forum. I will check back occasionally to see how you guys are doing. And update you on my new mobo

Good Luck!!!!!!!!!!!

User avatar
jtm55
Legit Fanatic
Legit Fanatic
Posts: 140
Joined: Sun Apr 10, 2005 9:01 pm
Location: Long Island NY

Post by jtm55 » Fri Jan 12, 2007 11:25 am

Hi All,

That's good news Progolf. My board will be here on the 16th. Intel is also refunding me my money as well.

Post Reply